Java not running with Mac OS 10.6

Yesterday my MacBook Pro would no longer let me log into my bank account (as well as many other web sites). In Denmark a lot of web services utilizes a central login service called “NemID” (translates to EasyID). This login procedure uses a Java applet (don’t get me started on design choices!!). And it turns out to be not-so-EasyID, when your browser (or computer) no longer runs Java. And this was exactly what happened – I could no longer run Java. Apple simply – and without warning – decided that Java was too big a risk and that I didn’t need it any longer (don’t get me started on how much I loath Apple (and Java for that matter) right now!). Well guess what, Apple, I do need it!!

So I did some googling and found this solution somewhere:

First of all – This fix does leave your computer vulnerable to certain Java exploits. Do not go ahead with this if you do not know what you’re doing. And Please make a backup of the file you’re editing!!!

And now lets get to the nitty-gritty: Open /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist in your favorite text editor – you need to do this with superuser roots permissions e.g.:

a. Open Terminal (Cmd+Space to open “Spotlight”-> Type “terminal+enter” to launch)

b. To open the Xprotect.meta.plist into TextEdit as root, enter:

sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist

You will be asked to enter your password – do as you’re told 🙂 The File should now open in TextEdit.

c. change the following values:

<key>JavaWebComponentVersionMinimum</key>
<string>1.6.0_37-b06-435</string>

to

<key>JavaWebComponentVersionMinimum</key>
<string>1.6.0_37-b06-434</string>

and

<key>MinimumPlugInBundleVersion</key>
<string>1.7.11.22</string>

to

<key>MinimumPlugInBundleVersion</key>
<string>1.7.11.21</string>

and last but not least, change

<key>LastModification</key>
<string>Thu, 31 Jan 2013 16:55:59 GMT</string>

to some date in the future. This will prevent the XProtect.meta.plist file from being updated until the date specified.

d. Now save (archive) the file and restart your browser and Voila! – Java applets should be able to launch again (you may need to reactivate by clicking “Inactive Plug-In” though)

Hope this helps, It sure helped me.

One Response to “Java not running with Mac OS 10.6”

  1. Reputation Management For Actors Says:

    Reputation Management For Actors

    Franks Blog » Blog Archive » Java not running with Mac OS 10.6

Leave a Reply